Résoudre le problème de connexion des NAS avec OSX Lion

 

Si comme moi vous avez rugit sur la mise à jour d’OSX et que vous avez un NAS vous êtes certainement tombé sur ce problème.

Pas très cool le Lion ! Apple aurait supprimer le support du « DHCAST128 » grâce auquel les principaux NAS (non siglé de la pomme) autorise les connexions.

Après avoir un peu chercher sur internet j’ai trouvé une solution qui fonctionne sur mon mac. Une solution qui va vous faire rebooter 3 fois vôtre mac et tapez des choses obscures sur vôtre clavier.

Voici ce qu’il faut faire en essayant de respecter autant que possible les étapes.

  1. Ouvrir le Terminal : dans vos applications, utilitaires, terminal

  1. Taper les 2 instructions suivantes dans le terminal :

sudo chmod o+w /Library/Preferences ( on vous demandera certainement votre mot de passe, alors donner le)

defaults write /Library/Preferences/com.apple.AppleShareClient afp_host_prefs_version -int 1

  1. Redémarrer vôtre mac.

  2. Ouvrir le finder et essayer de vous connecter ( ça ne va pas marcher mais pas d’inquiétude ).

5. Taper les 3 instructions suivantes dans le terminal :

sudo defaults write /Library/Preferences/com.apple.AppleShareClient afp_disabled_uams -array “Cleartxt Passwrd” “MS2.0″ “2-Way Randnum exchange”

sudo chmod o-w /Library/Preferences

sudo defaults write /Library/Preferences/com.apple.AppleShareClient afp_disabled_uams -array-add “DHCAST128″

6. Redémarrer vôtre

7. Ouvrir le finder et essayer de vous connecter ( normalement là ça devrait fonctionner ! )

Cette solution a très bien fonctionné avec mon NAS Buffalo Linkstation. Si vous ne vous vous sentez pas de faire toute cette manipulation vous pouvez également supprimé les restrictions d’accès et vous connecter en tant qu’invité, c’est moins sécurisé mais ça fonctionne très bien !

MAJ : Buffalo a réagit assez vite et viens de mettre à jour le firmware de linkstation qui résout ce problème. ( http://www.buffalo-technology.com/support/downloads/ls-chl-linkstation-live/ )

À propos de l'auteur jeromep

Blogger, Photographe Amateur

Website Facebook Twitter Instagram

5 commentaires

  • cola

    Eh non, Buffalo ne réagit pas vite du tout, du moins en ce qui concerne les utilisateurs de la version précédente du NAS LS-CHL (1 an et demi d’âge).
    4 mois après la sortie de Lion, toujours pas de Maj firmware du nas et donc, malgré votre astuce (qui marche chez moi pour l’accès aux volumes partagés), pas de fonctionnement de Time machine avec le Nas.
    Le forum de Buffalo grossit de plaintes, il n’y a aucun support et le seul discours tenu c’est « on a informé les ingénieurs japonais, on a pas de retour, mais ca va venir ». Bravo le support.
    Je suggère chacun d’investir ailleurs que chez Buffalo.

  • @cola

    Si votre NAS LS-CHL v2 (c’est le v2 l’important), la dernière version du firmeware est censé résoudre le problème :

    Ver.1.54 [2011.8.11]
    – Now officially supports Time Machine backup for Mac OS X v10.7 Lion.

    En revanche je comprend votre énervement, la réactivité de Buffalo n’est vraiment pas bonne!

  • regnier

    Moi non plus je recommanderai pas buffalo a un ami, j’ai pu faire la mise a jour mais depuis mon linkstation de démarre pas, la lumière bleue n’arrête jamais de clignoter.
    J ai essayé de mode EM mais ça n’a rien donné. http://forums.buffalotech.com/t5/Storage/FAQ-1-of-5-EM-Mode-boot-procedures-please-read-this/td-p/68102

    Je voulais faire la procédure TFTP mais je trouve pas les fichiers nécessaire pour mac, avez vous le meme problème, y a t il un endroit ou on peut trouver le TFTP boot image pour mac os?

    Merci d’avance

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée.